임베디드 | 라즈베리파이 | ARM | 리눅스 | Qt | 딥러닝

raspberry pi 1에서 2로 migration 하면 GPIO 가 동작하지 않는다

원래 잘 되던것이 갑자기 안되서 계속 끙끙되다가

역시나 답은 나와있었다

라즈베리파이 1에서 사용하던 모듈은 2에서 사용이 안되고

온라인상에서 설치하라는것들은 다 구버전용이었다



http://raspberry-python.blogspot.kr/2015/02/raspberry-pi-2-and-rpigpio.html

여기서 설치하라는데로 설치해도 안되는데 아래 댓글에 깃허브에서 직접 받아서 해보라고한다


해보니 잘됨

https://github.com/metachris/RPIO


단, 두번의 명령어로 해결

$ sudo apt-get install python-setuptools 

$ sudo easy_install -U RPIO


몇시간동안 삽질했네

역시 문제 해결은 가까운 곳에


이제 슬슬 프로젝트 마무리가 다되어 간다. 

재밌는 작품이 나올것 같다.



Comment +0